Posted on April 7, 2021 2:16 am
 |  Asked by Tamara
 |  43 views
Tags:
RESOLVED
0
0
Print Friendly, PDF & Email

Hi,

I have an Arista 7124FX switch, and I’m trying to add a static ARP entry to the ARP cache with the

arp <ipv4_addr> <mac_addr> arpa

command, and, while this does not give an error, the arp cache still remains seemingly empty when I use the

show arp

command. Is there anything else I should have done to add entries to the cache?

0
Posted by Lalitha Prasuna
Answered on April 7, 2021 2:17 am

Hi Tamara,

"arp <ipv4_addr> <mac_addr> arpa" is indeed the right command to configure static ARP. 
 
Are you trying to change the MAC address of a routed/ SVI/ sub-interface by any chance?
 
7124 being an end of support and the last code version this supports being pretty old could be the reasons for the use case you are trying to test be unsuccessful. 
 
Do you mind testing the same on a newer platform with the latest version and engage us at support@arista if the issue is still not resolved?

Cheers,
Lalitha Prasuna
1
Answered on April 7, 2021 4:23 am

Hi Tamara,

Thanks for reaching out.

I have tested this on one of the 7124 devices and I could see that static ARP entry is being populated in arp cache along with dynamic ARP entries.

switch(config)#arp 30.30.30.2 00:0a:00:0a:00:0a arpa

switch(config)#sh ip arp
Address            Age (min)          Hardware                       Addr Interface
30.30.30.2           -                 000a.000a.000a     Ethernet24
10.81.116.1              0                  dead.beef.cafe               Management1

 

For the ip address that is being configured for static arp(i.e 30.30.30.2 in this case), atleast one of the interfaces on the device needs to have ip assigned/configured in that subnet range for which we are configuring static ARP or SVI needs to be configured for that Vlan.

In this scenario I have ip add 30.30.0.1/16 configured on one of the physical interfaces.

switch(config)#sh ip int b
Interface          IP Address            Status   Protocol      MTU
Ethernet24        30.30.0.1/16       up           up             1500
Loopback0        10.8.180.1/32          up            up           65535

Also I have tried configuring static arp for another address and I could see that arp entry not being populated in arp cache.

The reason being that none of the interfaces(either L3 or SVI) on the device has ip address assigned in the subnet range of configured ip address for static arp.

switch(conf)#arp  40.40.40.1  b.b.b  arpa

switch(config)#sh ip arp                         --->No arp entry for 40.40.40.1
Address            Age (min)          Hardware                       Addr Interface
30.30.30.2           -                       000a.000a.000a     Ethernet24
10.81.116.1              0                    dead.beef.cafe               Management1

 

Thanks,

Bhavana.

Post your Answer

You must be logged in to post an answer.