Posted on January 7, 2022 9:09 am
 |  Asked by anggie.pratama
 |  103 views
RESOLVED
0
0
Print Friendly, PDF & Email

Hello, we have 8 device 7050SX3 with standard LEAF-SPINE configuration, and every one hour, each device consume high CPU utilization in short of a time (around 1 minutes) because of ConfigAgent process (please see attachment). What cause this issue? Thank you.

Attachments:
0
Answered on January 7, 2022 12:46 pm

Hi Anggie,

Thanks for reaching out.

ConfigAgent is responsible for all the configuration states of the system and consequently all of the CLIs in the system.
Basically to Configure the system.

Could you please answer the below queries:

1)Are there any automated scripts/event-handlers that have been running hourly on the devices?

2)Are there a high no of requests incoming on the switch (show management api http-commands ) ?

3)Are we executing a high number of commands on the devices?

4)Do all the devices show high CPU for ConfiAgent at the same time?

 

For further investigation, we might need to look into tech-support log(show tech-support | no-more) and other standard logs(agents logs, history tech-supports, agent qt, logging system, etc.,) to get more idea regarding the issue hence I would suggest opening a TAC case by dropping a mail to support@arista.com mentioning the problem statement and collected logs and we can further troubleshoot this issue.

 

Thanks,

Bhavana.

1
Posted by Tamas Plugor
Answered on January 8, 2022 12:41 am

If it's at the exact same time the hourly scheduled show-techs are running, that would one reason. You can check the time on the scheduled showtechs in /mnt/flash/schedule/tech-support/ folder

Thanks,

Tamas

0
Posted by anggie.pratama
Answered on January 15, 2022 7:26 am

Wow you're right! Thank you so much Tamas!

And thank you Bhavana. This case is closed.

Post your Answer

You must be logged in to post an answer.