Posted on September 14, 2020 8:08 am
 |  Asked by MOHAMMAD IQBAL ISA
 |  33 views
RESOLVED
0
0
Print Friendly, PDF & Email

Hi, i’m still new with Arista and I try to connect my vEOS using eAPI but I encounter this error

Socket error during eAPI connection: [WinError 10061] No connection could be made because the target machine actively refused it

arista1#show management api http-commands
Enabled: Yes
HTTPS server: running, set to use port 443
HTTP server: shutdown, set to use port 80
Local HTTP server: shutdown, no authentication, set to use port 8080
Unix Socket server: shutdown, no authentication

I’m guessing it because the HTTP server is in shutdown mode? because when I specify the connection to use HTTPS, it works well.

additional info:

vEOS is reachable thru ping.

Any suggestion on how do i enable the http sever?

1
Answered on September 14, 2020 8:09 am

Hi Iqbal,

Thanks for reaching out.

We need to enable protocol http under management api http-commands.Please find the below:

switch(config)#management api http-commands
switch(config-mgmt-api-http-cmds)#protocol http ——>This needs to be enabled.
switch(config-mgmt-api-http-cmds)#protocol https
switch(config-mgmt-api-http-cmds)#no shutdown

switch(config-mgmt-api-http-cmds)#sh management api http-commands
Enabled: Yes
HTTPS server: running, set to use port 443
HTTP server: running, set to use port 80
Local HTTP server: shutdown, no authentication, set to use port 8080
Unix Socket server: running, no authentication

 

Let us know if the above works.
In case if the above doesn't help then could you please check if there is any firewall between switch and server which is not allowing HTTP traffic.

Thanks,
Bhavana.

0
Posted by MOHAMMAD IQBAL ISA
Answered on September 21, 2020 3:26 am

Thank you Mr/Ms Bhavana. Really appreciate it a lot.

Post your Answer

You must be logged in to post an answer.