Posted on September 1, 2021 3:31 pm
 |  Asked by Gabor Luky
 |  83 views
RESOLVED
0
0
Print Friendly, PDF & Email

I have encountered an issue with my CloudVision VM. After a while the web GUI stopped to respond, the login screen didn’t appeared. I reloaded the CVP VM but even after that CVP can’t boot up. Login to the shell I can see only the Localhost interface is up. When I try to verify my cvp config (su cvpadmin, verify) I receive error: no space left on device.

But when checking cvpi resource it seems there is enough free space (see 2.png).

When trying to start cvpi with cvpi start all command I receive some ZK lock coulnd’t be created: zk: couldn’t connect to server errror.

Unfortunately cvpi backup command is exiting with the same error, so I can’t backup and restore my system. Is there any workaround to restore my system?

 

 

Attachments:
0
Posted by Tamas Plugor
Answered on September 1, 2021 9:00 pm

Hi Gabor,

cvpi resources will show you how much space you have on /data, not on the root partition, which is probably where you've run out of free space. You can try using this cleanup script and see if that helps https://github.com/arista-netdevops-community/cvp-space-recovery
I suggest opening a TAC case if you have further issues by sending an email to support@arista.com

Thanks,
Tamas

0
Posted by Gabor Luky
Answered on September 2, 2021 11:58 am

Thank you (Köszönöm Tamás)!

Even I was not able to upload the script - as network service was down as well - based on script description I was able to delete some log files, which immediately solved the issue. CVPI and network service was able to boot up.

After that with working network service I've uploaded the cleanup.py script and deleted all the other unnecessary files. It seems for some reason the kubelet logs consumed the drive space with around 13GB...

Now my system is up and running again.

Thank you for your support.

 

0
Posted by Tamas Plugor
Answered on September 2, 2021 5:26 pm

Nagyon szívesen! :)

Post your Answer

You must be logged in to post an answer.