Posted on June 22, 2021 2:53 am
 |  Asked by annie
 |  143 views
RESOLVED
0
0
Print Friendly, PDF & Email

Need some guidance on multicast implementation where we need to enable for video streams.

  • Standard Spine and Leaf setup with multiple vlans
  • both receivers and source are located in Vlan 10 at different location/vtep
  • enabled igmp snooping + querier on all vtep
  • receiver located at different vtep from the source are not receiving any stream

Trying to find documentation on what i may missed or if any experts can provide any clues.

 

0
Posted by Aniket Bhowmick
Answered on June 22, 2021 8:16 am

Hi Annie

Thanks for posting your query on EOS Forum !

  1. You should not configure IGMP Snooping on a VTEP as it is not supported. IGMP report packets received on Vxlan Tunnel interface will not be "snooped". Hence any Multicast packet, that was supposed to egress out of Vx1 interface will instead be dropped (as long as snooping is active). Please disable snooping globally and also for the Vlan using the below commands on ALL VTEPS-
    • (config)#no ip igmp snooping
    • (config)#no ip igmp snooping vlan <vlan-id>
    • "show ip igmp snooping"         <--- Verify if snooping is disabled
  2. Please do remove any "PIM" configurations that you have configured from all the VTEPs.
  3. With this, the VTEP would "flood" both Multicast traffic and the IGMP reports and setup should work (considering the rest of the Vxlan configs are correct- VNI/floodlist).
  4. But the drawback with this is, Multicast traffic will be flooded to all VTEPs in the floodlist. This is how it is supposed to work with just Vxlan+Multicast.

But if you are planning on configuring EVPN too, you can make use of the L2EVPN/L3EVPN support for Vxlan+Multicast. It uses various signalling (EVPN Type-6,7,8,10 routes)  to other VTEPs if a user is connected requesting for Multicast traffic and avoids unnecessary flooding. It also supports Active-Active Multi Homing with DF. Please find the below articles which can help you understand this feature better:

  • L2 Multicast EVPN (vlan is extended)- https://eos.arista.com/eos-4-25-1f/layer-2-multicast-evpn/
  • L3 Multicast EVPN (vrf is extended)- https://eos.arista.com/eos-4-25-1f/multicast-evpn-irb/A
  • A-A Multi homing: https://eos.arista.com/eos-4-25-1f/multicast-evpn-all-active-multihoming/

We would also suggest to discuss with your Arista SE once who can guide you with the right design as per your network requirement.

Regards,

Aniket

0
Posted by annie
Answered on June 22, 2021 9:00 am

Hello Aniket,

Thanks for your reply. My bad, snooping is not enabled, only querier as per below :

ip igmp snooping vlan 10 querier address <loopback0>
ip igmp snooping querier

Will the above be enough for multicast for now, but of course we will optimize the configs once we've decided which approach to take.

0
Posted by Aniket Bhowmick
Answered on June 23, 2021 3:13 am

Hi Annie

IGMP snooping is "Enabled" by default on Arista EOS. However, though it is Enabled, it is inactive state until and unless it receives an IGMP query in any Vlan or itself becomes the querier.

Did you explicitly disabled igmp snooping ?

If you run "show ip igmp snooping", you should see IGMP snooping is enabled globally if you didn't disable it (even though you didn't enable it as well).

Hence, you do need to disable IGMP snooping explicitly and also remove the querier configuration as it is not needed:

  • (config)#no ip igmp snooping
  • (config)#no ip igmp snooping vlan <vlan-id>
  • "show ip igmp snooping"         <--- Verify if snooping is disabled
  • (config)#no ip igmp snooping querier
  • (config)#no ip igmp snooping vlan 10 querier address <loopback0>

After this verify if Multicast streaming is working or not. If not, you need to check if all Vxlan configurations are correct or not- check the VLAN/VNI mapping on all VTEPs, Floodlist, route to reach remote VTEPs (underlay).

Regards,

Aniket

0
Posted by annie
Answered on June 29, 2021 10:27 am

Hi,

Apology for the late reply.

If the 'no ip igmp snooping' and 'no ip igmp snooping querier' configured, multicast wont work at all (not even on the same switch)

Checked all VTEPS routes and working fine, multicast traffic in this vlan is not working without any 'igmp snooping' command. Only the below command is entered for it to work within same switch and igmp snooping is still enabled :

ip igmp snooping querier address <x>

Thanks.

0
Posted by Aniket Bhowmick
Answered on June 30, 2021 4:57 pm

Hi Annie

  • If "ip igmp snooping" or PIM is enabled on a switch which is a VTEP, any Multicast packets received by the VTEP from a downstream "sender" on a L2 port will not Vxlan Encapsulated. This is because, Vxlan tunnel interface (Vx1) will not be present in the snooping table ("show ip igmp snooping groups").
  • Since snooping is enabled, the Multicast packet will not even get flooded (flooding is false if snooping is enabled and active).
  • If snooping is enabled but not active (no querier is learnt or it is itself is not a querier) then it will flood the Multicast packets in Vxlan and all other ports in the Vlan as flooding would be true, but it won't be able to flood IGMP reports and hence the reports won't get Vxlan encapsulated.
  • To make sure the VTEP can flood both Multicast data packets and IGMP reports you need to disable IGMP Snooping globally on the VTEP and remove any PIM related configuration. This is a day-1 limitation.

Also, I would suggest if you can get in touch with your Arista SE who can suggest you with better design as per your requirement.

Regards,

Aniket

0
Posted by annie
Answered on July 1, 2021 11:44 pm

Thanks for that, unfortunately our support with Arista expired at this moment, hence couldnt get any answers and we are trying to ensure Multicast will be supported over vxlan and implemented the config below in our test environment.

https://eos.arista.com/eos-4-25-1f/layer-2-multicast-evpn/

From the above doc/link, mentioned that Snooping must be enabled or am i reading this wrongly ?

Rgds.

0
Posted by Aniket Bhowmick
Answered on July 2, 2021 6:32 am

Hi Annie

In one of my earlier response in this thread I mentioned the following:

----------------------------------------------------------------------------------------------------

If you are planning on configuring EVPN too, you can make use of the L2EVPN/L3EVPN support for Vxlan+Multicast. It uses various signalling (EVPN Type-6,7,8,10 routes)  to other VTEPs if a user is connected requesting for Multicast traffic and avoids unnecessary flooding. It also supports Active-Active Multi Homing with DF. Please find the below articles which can help you understand this feature better:

  • L2 Multicast EVPN (vlan is extended)- https://eos.arista.com/eos-4-25-1f/layer-2-multicast-evpn/
  • L3 Multicast EVPN (vrf is extended)- https://eos.arista.com/eos-4-25-1f/multicast-evpn-irb/A
  • A-A Multi homing: https://eos.arista.com/eos-4-25-1f/multicast-evpn-all-active-multihoming/

The solution that I provided (disabling IGMP Snooping on VTEPs) is just for Vxlan without EVPN (where all Multicast traffic are simply flooded in Vxlan fabric). If you plan on using Vxlan + EVPN+ Multicast, you need to have the IGMP snooping enabled as you mentioned.

Hope this helps.

Regards,

Aniket

Post your Answer

You must be logged in to post an answer.