Posted on March 13, 2017 6:46 pm
 |  Asked by LINH PHAN
 |  418 views
RESOLVED
0
0
Print Friendly, PDF & Email

Hi everyone,

I’m trying to install Arista L3 plugin to work with OpenStack Newton. So far everything work great with all the authentication completed, VLAN network created and show normally on the CVX.

CVX management between the Switch and CVX is established 

However I got stuck when create a router, using the either CLI and Horizon for any tenants. 

The error in short: 

ERROR networking_arista.l3Plugin.arista_l3_driver SSLError: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)

Full version: http://pastebin.com/nc7LHHpY

I think it somehow get stopped at SSL verification. I have tried to use the physical EOS Switch and vEOS, but yield same error. 

I have doubled check the username,password, and 100% sure that the connectivity is through. I’m able to go to each switch’s web GUI (https) to execute some commands, and I followed all steps in Mitaka deployment guide from Arista.

#In /etc/neutron/neutron.conf

service_plugins = arista_l3

#In /etc/neutron/plugins/ml2/ml2_conf.ini

mechanism_drivers = openvswitch,linuxbridge,arista

#In /etc/neutron/plugins/ml2/ml2_conf_arista.ini

[ml2_arista]

[l3_arista]

Database has already migrated.

 

Thank you

 

0
Posted by Kamlesh Sharma
Answered on April 25, 2017 4:31 am

Hi Linh Phan,

Could you please have look at the below openstack. We hope that it will fix it for you. 

https://review.openstack.org/#/c/443949/ 

Post your Answer

You must be logged in to post an answer.