Posted on June 29, 2020 6:41 pm
 |  Asked by Roman Banishevsky
 |  136 views
0
0
Print Friendly, PDF & Email

Hi all!

I trying configure QinQ on Arista DCS-7050QX-32-F, eos version is 4.20.7m.

Network topology is placed in attachment.

Arista DCS-7050S-64-F config: 

interface Ethernet5
description to_Aquatoria_office_e1/0/52
mtu 4096
speed forced 1000full
switchport trunk allowed vlan 7,10,12,14,500,4020
switchport mode trunk
ip igmp version 2

interface Ethernet43
description to_Arista-Spine_et16/1_test_mcast
mtu 4096
switchport trunk allowed vlan 4020
switchport mode trunk

interface Ethernet44
description to_Arista-Spine_et16/2_test_mcast
mtu 4096
switchport trunk allowed vlan 4010
switchport mode trunk

interface Vlan4010
ip address 10.255.255.2/29

Arista DCS-7050QX-32-F

interface Ethernet16/1
description to_SG-Arista_test_et43
mtu 4096
switchport trunk allowed vlan 4020
switchport mode trunk

interface Ethernet16/2
description to_SG-Arista_test_et44
mtu 4096
switchport access vlan 4020
switchport mode dot1q-tunnel

I can’t ping vlan4010 on Arista DCS-7050S-64F from my PC, but I see correct mac addresses on vlan 4020:

SG-Arista-Spine#show mac address-table dynamic vlan 4020
Mac Address Table
——————————————————————

Vlan Mac Address Type Ports Moves Last Move
—- ———– —- —– —– ———
4020 001c.734e.e8d9 DYNAMIC Et16/2 1 0:00:01 ago
4020 503e.aa93.aeb7 DYNAMIC Et16/1 1 0:47:47 ago
Total Mac Addresses for this criterion: 2

ARP-table on Arista 7050S:

SG-Arista#show arp 10.255.255.1
Address Age (min) Hardware Addr Interface
10.255.255.1 N/A 503e.aa93.aeb7 Vlan4010, Ethernet44

ARP-table on PC:

user@PC ~ % arp -a | grep 10.255.255.2
? (10.255.255.2) at 0:1c:73:4e:e8:d9 on vlan4010 ifscope [vlan]

What’s wrong? Why doesn’t it work? Help me please

Regards,

Roman

Attachments:
0
Posted by Shishio Tsuchiya
Answered on June 30, 2020 4:19 am

Does SNR another vender? I think you should confirm what ether-type they are using.
We can change the ether-type to match the SNR if it is needed.
https://www.arista.com/en/um-eos/eos-section-21-4-vlan-configuration-commands#ww1167812

0
Posted by John Gill
Answered on July 9, 2020 2:51 am

It appears the SNR switch is the beginning of the Q-in-Q tunnel and the Arista 7050S is not involved with terminating the tunnel.  The 7050S will see all traffic within VLAN 4020 and does not know about 4010.

I am not sure where you want the tunnel to terminate, but you will need it to decapsulate the S-tag before the Arista has access to C-tags.

I have drawn a diagram that is perhaps not exactly what you want, but it shows how you can pass traffic through a switch and then decap/terminate the tunnel and pass the inner VLANs (C-tags) to another switch.

 

Essentially you tread the already tagged traffic as if it's in the S-tagged VLAN and you can trunk it through without knowledge of the q-in-q tagging.  The tunnel is terminated wherever the interface is in mode dot1q-tunnel and you set the access VLAN to that of the S-tag, being stripped or added, depending on direction.

image describing q-in-q tunnel termination of pre-tagged traffic

Regards,

John Gill

Post your Answer

You must be logged in to post an answer.