Posted on May 11, 2020 9:09 am
 |  Asked by Zelda Park
 |  89 views
RESOLVED
0
0
Print Friendly, PDF & Email

Hi,

Device Details:

Arista DCS-7050S-52-R
Hardware version: 01.03
Software image version: 4.15.3F

I am having an issue where I am seeing random traffic drops on only one port. In one incident all the traffic was dropped however in the majority of cases only 400 Mbps – 800 Mbps of traffic is lost causing some users to not have connectivity while others still do. Traffic loss lasts between 3 – 5 minutes and then fully restores.

Checking physical port counters there are no errors on the port either side of the connection, transceiver levels are well within normal limits. Further investigation lead me to check platform debug counters:

Platform Debug Counter Output:
Just after finding the issue the I had the following counter values:

#show platform trident counters interface ethernet 1 | nz
Debug counters

Description                                                     Value
Ethernet1 RX – IPV4 L3 Discard                                   99493
Ethernet1 RX – IPV6 L3 Discard                                   20
Ethernet1 RX – Non congestion discards                    25400584
Ethernet1 RX – Packets dropped by FP                       11201787
Ethernet1 RX – Receive multicast drop                       39
Ethernet1 RX – Receive policy discard                        3
Ethernet1 RX – IPV4 header error                               5
Ethernet1 RX – Receive VLAN drop                            294909
Ethernet1 RX – Good IPV4 L3 Unicast                       192144031306
Ethernet1 RX – Good L2, L3 unicast                           192155660649

1 Week after clearing the counters: (AND NOT EXPERIENCED ANY FURTHER DROPS)

#show platform trident counters interface ethernet 1 | nz
Debug counters

Description                                                   Value
Ethernet1 RX – IPV4 L3 Discard                                 49
Ethernet1 RX – Non congestion discards                  324598
Ethernet1 RX – Packets dropped by FP                     162548
Ethernet1 RX – Good IPV4 L3 Unicast                      2747454591
Ethernet1 RX – Good L2, L3 unicast                          2747622910

Interface configuration:

#show run int Et1
interface Ethernet1
load-interval 30
switchport trunk allowed vlan 10
switchport mode trunk

#show run int vl 10
interface Vlan10
ip address 10.0.74.1/23
ip address 10.0.66.121/29 secondary
ip address 10.0.78.1/23 secondary
ip address 10.0.84.1/24 secondary
ip helper-address 172.16.104.82
#

My Question : 

What would cause the following 2 counters to increase:

RX – IPV4 L3 Discard

RX – Receive VLAN drop

Can this be indicative of an issue that would cause the drops in traffic that we have experienced?

Is there any further checks I can do to identify the cause of the issue?

 

 

1
Posted by Aniket Bhowmick
Answered on May 11, 2020 9:58 am

Hi Zelda,

IPV4 L3 Discard. --> These drops are legitimate drops that can happen if you have configured some ACLs or if there is some kind of static "drop" configured for the corresponding DMAC (after routing).

Can you tell us if you have configured any kind of ACL on the switch ? If yes, can you check if all the rules in the ACL (or ACLs) are properly configured? Make sure all rules permits all traffic (based on Source IP and Destination IP) that needs to be routed on the switch, if some flow is missing, it will be dropped implicitly.

RX – Receive VLAN drop.  --> This drop will happen if you receive a packet on a L2 interface with a Vlan tag (say Vlan: 1000) which isn't allowed on that interface. In that case the packet will be dropped and the counter for that interface (where packet was received) would increment. This can happen if you have allowed some Vlans on the opposite interface (of Eth1) but not allowed on Ethernet1.

Can you check if the Vlans that is allowed on Ethernet1 is also allowed on the interface opposite to Ethernet1 (should be same on both ends) ?

Also, if you see issue is still occurring, then feel free to contact Arista TAC.

Regards,

Aniket

Post your Answer

You must be logged in to post an answer.