Posted on June 4, 2019 6:21 pm
 |  Asked by Chirag
 |  169 views
0
0
Print Friendly, PDF & Email

Hi All,

I am trying to create a GNS3 lab with Arista + Cumulus for VXLAN BGP EVPN. I am using Cumulus as Spine and Arista as Leaf switch. I am getting issue setting up EVPN. BGP sessions are coming up while EVPN sessions giving error message like “Estab(NotNegotiated)”
Topology summary
Spine – Cumulus
Leaf – Arista
Underlay – OSPF
Overlay – BGP EVPN

Here is the config set up and show command output for reference. Would someone please help me to understand what i am doing wrong?

Arista Leaf Switch Config

! Command: show running-config
! device: leaf5 (vEOS, EOS-4.18.1F)
!
! boot system flash:EOS.swi
!
transceiver qsfp default-mode 4x10G
!
service routing protocols model multi-agent
!
hostname leaf5
!
spanning-tree mode mstp
!
no aaa root
!
vlan 10,20
!
interface Ethernet1
switchport access vlan 10
!
interface Ethernet2
switchport access vlan 20
!
interface Ethernet3
!
interface Ethernet4
!
interface Ethernet5
no switchport
ip address 10.10.15.2/24
ip ospf network point-to-point
ip ospf area 0.0.0.0
!
interface Ethernet6
no switchport
ip address 10.10.25.2/24
ip ospf network point-to-point
ip ospf area 0.0.0.0
!
interface Ethernet7
!
interface Loopback0
ip address 1.1.1.7/32
!
interface Management1
!
interface Vlan10
ip address 192.168.10.1/24
!
interface Vlan20
ip address 192.168.20.1/24
!
interface Vxlan1
vxlan source-interface Loopback0
vxlan udp-port 4789
vxlan vlan 10 vni 10010
vxlan vlan 20 vni 10020
!
ip routing
!
router bgp 65000
router-id 1.1.1.7
neighbor 10.10.15.1 remote-as 65000
neighbor 10.10.15.1 send-community extended
neighbor 10.10.15.1 maximum-routes 12000
neighbor 10.10.25.1 remote-as 65000
neighbor 10.10.25.1 send-community extended
neighbor 10.10.25.1 maximum-routes 12000
!
address-family evpn
neighbor 10.10.15.1 activate
neighbor 10.10.25.1 activate
!
address-family ipv4
neighbor 10.10.15.1 activate
!
router ospf 1
router-id 1.1.1.7
network 1.1.1.7/32 area 0.0.0.0
max-lsa 12000
!
end

leaf5#show ip bgp sum
BGP summary information for VRF default
Router identifier 1.1.1.7, local AS number 65000
Neighbor Status Codes: m – Under maintenance
Neighbor V AS MsgRcvd MsgSent InQ OutQ Up/Down State PfxRcd PfxAcc
10.10.15.1 4 65000 1783 2095 0 0 01:29:01 Estab 0 0
10.10.25.1 4 65000 1358 1613 0 0 01:07:45 Estab 0 0
leaf5#
leaf5#
leaf5#
leaf5#
leaf5#show bgp evpn summary
BGP summary information for VRF default
Router identifier 1.1.1.7, local AS number 65000
Neighbor Status Codes: m – Under maintenance
Neighbor V AS MsgRcvd MsgSent InQ OutQ Up/Down State PfxRcd PfxAcc
10.10.15.1 4 65000 1789 2102 0 0 01:29:21 Estab(NotNegotiated)
10.10.25.1 4 65000 1364 1620 0 0 01:08:05 Estab(NotNegotiated)
leaf5#

0
Posted by Alex
Answered on June 4, 2019 6:29 pm

Can you send the output of the CLI command :

show ip bgp neighbors 10.10.15.1
show ip bgp neighbors 10.10.25.1

You are also using an old version of EOS (EOS-4.18.1F) would it be possible to upgrade to an newer version 4.22, to get all the available EVPN functionality.

Alex

0
Posted by Shreyas Ruwala
Answered on June 4, 2019 6:43 pm

Hi Chirag,

Thank you for sharing the details of the lab.
To undertsand the issue better, please share following information
1. Topology with interfaces labelled out
2.pcap capture on the interface(s) between Arista and Cumulus, it would be interesting to see what capabilities BGP protocols is advertising in its OPEN message while trying to form EVPN neighborship with Cumulus and vice versa scenario as well

Sincerely,
Shreyas Ruwala
Technical Solutions Engineer – Arista Networks
Direct Support line: +1 919 312 9613 [10:00 AM to 16:00 EST] (GMT-4)
International Support line: +1 408 547 5502 or +44 207 023 9352
Toll-free Support line: +1 866 476 0000 (US), +44 808 234 0722 (UK)
Please call support if immediate assistance is required.

1
Posted by Chirag
Answered on June 7, 2019 7:01 pm

Thanks Alex, Shreyas for your input!

I apologies for late reply, It looks like 4.18 is giving me issue so will be trying with 4.21 in GNS3 and will share the output here

Post your Answer

You must be logged in to post an answer.